Signhost (Evidos) unavailable due to major outage
Incident Report for Blanco Services
Resolved
This incident has been resolved.
Posted Jun 22, 2020 - 13:56 CEST
Investigating
Signhost is down. They are investigating the issue. We will keep you updated via our statuspage.
Posted Jun 22, 2020 - 13:04 CEST
This incident affected: Know-Your-Customer Suite (Know-Your-Customer API, Professional Portal).